US Processing Delays
Incident Report for RDC
Resolved
This incident has been resolved and batches currently undergoing review.
Posted Jul 22, 2020 - 18:41 UTC
Monitoring
A fix has been implemented to ensure that RDC Review inquiries are being processed by our analyst team. We are monitoring the system and will advise when the processing backlog has cleared.

RDC Client Review customers are not impacted by this incident.
Posted Jul 22, 2020 - 15:53 UTC
Update
We are continuing to investigate this issue.
Posted Jul 22, 2020 - 15:31 UTC
Investigating
You may see inquiries in a processing state for longer than expected at this time.
Posted Jul 22, 2020 - 15:27 UTC
This incident affected: RDC US Region (GRID User Interface (US), GRID Batch processing (US), GRID API (US), View Data Analytics (US), AML Edge (US), CMF (Case Management Framework)).