We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 14:50 UTC
Update
Cloudflare has implemented a fix and the incident appears to be resolved. Access to GRID and SSO login functionality should now be restored and operating normally. We are continuing to monitor the situation closely to ensure stability across all services.
Posted Nov 18, 2025 - 14:49 UTC
Update
Cloudflare has identified a fix and is working towards restoring services. We will provide an update as soon as normal services are restored.
Posted Nov 18, 2025 - 13:33 UTC
Update
Cloudflare is continuing to investigate, services are currently down. We will continue to monitor the situation and provide an update in half an hour.
Posted Nov 18, 2025 - 13:04 UTC
Monitoring
Cloudflare services are starting to recover, clients may continue to experience issue as they continue remediation efforts.