Temporary Increase in Alert Volume Due to Technical Issue

Incident Report for RDC

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 13:33 UTC

Monitoring

Due to a technical issue, some customers may experience an additional volume of alerts being generated. These alerts correspond to screening that occurred on and between February 28, 2026 and March 3, 2026. Please reach out to your relevant contact if you have any questions.
Posted Mar 11, 2026 - 20:48 UTC
This incident affected: RDC Europe Region (GRID Batch processing (EU)).