GRID Services in United States are currently unavailable

Incident Report for RDC

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 15:30 UTC

Monitoring

We are monitoring the issue and will provide updates as available.
Posted Mar 31, 2026 - 15:22 UTC

Investigating

Please be aware that RDC have identified an issue impacting US services and the incident is under investigation.

You may currently be unable to access the RDC GRID web services, or Inquiry submissions may take longer than expected to return.
Posted Mar 31, 2026 - 14:25 UTC
This incident affected: RDC US Region (GRID User Interface (US), GRID Batch processing (US), GRID API (US), View Data Analytics (US), CMF (Case Management Framework)).