Portfolio Monitoring Delay in EU Region

Incident Report for RDC

Resolved

All batches have been processed and released.
Posted Feb 20, 2026 - 15:40 UTC

Monitoring

We are continuing to monitor the batch process and will provide an update when one is available.
Posted Feb 20, 2026 - 15:11 UTC

Identified

We are processing a larger than usual match rate for today's EU portfolio monitoring. PM batches are processing at this time, and we’ll provide updates as progress is made.
Posted Feb 20, 2026 - 14:43 UTC
This incident affected: RDC Europe Region (GRID Batch processing (EU)).