Unexpected Response Fields Impacting API Integration

Incident Report for RDC

Resolved

A hotfix has been successfully deployed to address the issue affecting clients with integrations that use strict response parsing against the /api/grid-service/v2/inquiry endpoint.

We have removed the unexpected response fields introduced in yesterday's release and restored the expected response format. Clients should no longer experience integration errors related to this issue.

We apologize for any disruption this may have caused and appreciate your patience while we worked to resolve the problem.
Posted Jul 15, 2026 - 18:14 UTC

Identified

We are aware of an issue affecting a limited number of clients following yesterday’s software release. Clients with integrations that use strict response parsing against the /api/grid-service/v2/inquiry endpoint may experience errors due to the presence of unexpected fields in the response payload.

Our team has identified the issue and is actively working on a hotfix to restore compatibility with integrations that are not tolerant of additional response fields. We will provide further updates as progress is made.

We apologize for any inconvenience and appreciate your patience while we work to resolve this issue.
Posted Jul 15, 2026 - 16:02 UTC
This incident affected: RDC US Region (GRID API (US)), RDC Europe Region (GRID API (EU)), and RDC India Region (GRID API (IN)).