Portfolio Monitoring Delay in EU Region

Incident Report for RDC

Resolved

All batches have been processed and released.
Posted Jul 12, 2026 - 14:50 UTC

Monitoring

We are processing a larger than usual match rate for a subset of today's EU portfolio monitoring. Remaining PM batches are processing normally, and we’ll provide updates as progress is made.
Posted Jul 12, 2026 - 13:48 UTC
This incident affected: RDC Europe Region (GRID Batch processing (EU)).