Portfolio Monitoring Delay in EU Region

Incident Report for RDC

Resolved

All client PM batches have been released.
Posted Oct 08, 2025 - 17:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2025 - 13:20 UTC

Identified

Portfolio matching is delayed due to high monitoring volume that is impacting select clients. The majority of clients will have their PM batches available normally, while we work through the processing delays for the affected clients. Updates will be provided as progress continues.
Posted Oct 08, 2025 - 13:20 UTC
This incident affected: RDC Europe Region (GRID Batch processing (EU)).