Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 07, 2025 - 01:00 UTC
Scheduled
Moody’s is set to enhance web application network access patterns to Grid applications and services in our US region by implementing Cloudflare Web Application Firewalls (WAF) at the edge of our network.
Upcoming Changes
Cloudflare offers cutting-edge technology solutions for web application protection, including traffic inspection, defence against denial of service attacks, risk mitigation from zero-day exploits, and other features that enhance the safety and reliability of our service delivery to customers.
This update involves eliminating the current static public IP addresses assigned to target services. Moving forward, we will discontinue static IP addressing due to advancements in technology that allow for dynamic updates. We urge customers currently using legacy IP-based allow listing to transition to Domain Name Server (DNS)-based allow listing for our domain names in their enterprise network egress policies. For any queries regarding this change, please consult your internal technology support teams.
Timeline
After November 7th, 2025 01:00 UTC, Moody’s will commence migrating services to the new ingress pattern. Consequently, there will be IP address modifications, as outlined below. The URLs for accessing services will remain unchanged, and there will be no alterations to service consumption. The transition to Cloudflare will be seamless with zero downtime.
If you currently rely on legacy IP-based allow listing, as specified below, we kindly request you to switch to DNS-based allow listing by November 7th, 2025, to ensure uninterrupted service access.
US Region
Current static IP addresses of 75.2.18.165 and 99.83.139.189
*While the Cloudflare IP list is provided, any future changes will not be individually notified, and IP addresses for service access may be altered at any time. Domain Name Service (DNS) resolution will be the sole supported access method for all web services.
Unchanged Aspects
There will be no modifications to Grid application egress network addresses, those used for API calls generated by Moodys to Customer endpoint integrations, or to our Secure File Transfer Protocol (SFTP) server for batch file uploads and downloads.
Queries
For any concerns or questions, please reach out to your Customer Success Manager (CSM) or contact our support team at clientservices@moodys.com
Posted Oct 31, 2025 - 01:01 UTC
This scheduled maintenance affected: RDC US Region (GRID User Interface (US), GRID Batch processing (US), GRID API (US), View Data Analytics (US), AML Edge (US), CMF (Case Management Framework)).