SSO Outage across all environments

Incident Report for RDC

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:08 UTC

Update

Cloudflare has implemented a fix and the incident appears to be resolved. SSO login functionality should now be restored and operating normally. We are continuing to monitor the situation closely to ensure stability across all services.
Posted Nov 18, 2025 - 14:50 UTC

Monitoring

We are currently investigating reports of SSO login failures. We have identified the root cause as a Cloudflare infrastructure issue impacting our SSO authentication service. Cloudflare is actively working to restore services. Our team continues to monitor.

The following URL is impacted: https://login.moodysanalytics.com
Posted Nov 18, 2025 - 14:25 UTC
This incident affected: RDC US Region (GRID User Interface (US)), RDC Europe Region (GRID User Interface (EU)), and RDC India Region (GRID User Interface (IN)).