GRID Services in United States are currently exhibiting batch process delays
Incident Report for RDC
Resolved
All processing delays have cleared from the US GRID Services. This incident is now resolved.
Posted Jul 24, 2020 - 15:55 UTC
Investigating
Please be aware that RDC have identified an issue impacting US services and the incident is under investigation.

You may currently be unable to access inquiries to make decisions or review results.
Posted Jul 24, 2020 - 12:23 UTC
This incident affected: RDC US Region (GRID User Interface (US), GRID Batch processing (US), GRID API (US)).