Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 08, 2026 - 05:25 UTC
Scheduled
AWS-enforced minor version upgrade scheduled for production database. Upgrade: PostgreSQL 15.10.R1 → 15.17.R2 Scheduled: August 8, 2026, 05:31 – 06:01 UTC Expected Duration: 30 minutes
Brief connectivity interruption expected during database restart. Services will be restored automatically upon completion.
This database is the replication source for the EU (Ireland, Frankfurt), India (Mumbai), and US West (Oregon) regions. Read-only services in those regions remain available throughout, but will serve data that is up to 30 minutes stale until replication catches up. Write operations routed to the US East primary will be briefly unavailable during the restart. Replication resumes and catches up automatically once the upgrade completes; no regional action is required.
Posted Aug 07, 2026 - 10:00 UTC
This scheduled maintenance affected: RDC US Region (GRID User Interface (US), GRID Batch processing (US), GRID API (US), View Data Analytics (US), AML Edge (US), CMF (Case Management Framework)).